Home > Questions

NTFS external hard drive not mounting after updating macOS

WD My Passport won't mount following the Catalina 10.15.7 security update and when trying to mount with Disk Utility I get this error (com.apple.DiskManagement.disenter error 49221.) I tried it on another Mac running macOS 10.15.7, it worked. Any suggestions or fixes out there?

Best Answered by

iBoysoft author Jenny Zeng

Jenny Zeng

Answered on Monday, April 29, 2024

If your WD My Passport NTFS hard drive doesn't mount after a macOS update, it likely results from the incompatibility between your NTFS driver and the new macOS. The fix is to use an NTFS mounter that's compatible with your operating system like iBoysoft NTFS for Mac.

You can check Western Digital's website or ask customer support to confirm whether your NTFS driver supports your current macOS version. If it does, you might need to update the driver. If updating the driver doesn't work, you can reboot your Mac or uninstall and reinstall the NTFS driver to fix the issue.

Suppose your NTFS driver isn't compatible with your macOS yet or your WD My Passport hard drive still won't mount in Disk Utility and click the Mount button returns the com.apple.DiskManagement.disenter error. Then don't hesitate to try iBoysoft NTFS for Mac. It's one of the best NTFS mounters for Mac in the market, which allows you to read and write to an NTFS drive natively. It supports a wide range of operating systems, from the latest macOS Ventura to the old macOS High Sierra.

Free download it to mount your NTFS hard drive on Mac!

People Also Ask

Read More Questions

Read More Advice From iBoysoft's Computer Experts

cómo convertir ntfs a fat32 en mac

Cómo Convertir NTFS a FAT32 en Mac Sin Perder Datos

Es posible que desee formatear una unidad NTFS a FAT32 para hacerla compatible con Macs y PCs con Windows. Esta publicación explica cómo convertir NTFS a FAT32 en Mac y cómo usar NTFS en Mac sin formatear.

SonomaでのMacログインパスワードの変更

Macでログインパスワードを変更する方法

この投稿は、Macでのログインパスワードの変更方法をステップバイステップで案内します。macOS Sonoma/Ventura/Monterey/Big SurでMacのパスワードを変更する詳細な手順に従ってください。

cant create new folder on Mac desktop

[Solved] Can't Create a New Folder on Mac Desktop & Finder

Follow this post to learn why you can't create a new folder on the Mac desktop or in Finder and follow the mentioned solutions to fix this issue.

How to Tips