Home > Questions

How to Fix SanDisk Flash Drive Not Detected by My MacBook Air?

Hi, I’m using a Macbook Air M1 and when I connect a SanDisk 64GB Flash Drive to the Type-C port, the system is not detecting it. I have tried enabling the external drives option in Finder > Preferences but it is not working and the flash drive is yet not detected. Please help me in figuring out the solution for this problem. Thank you.

Best Answered by

iBoysoft author Vain Rowe

Vain Rowe

Answered on Thursday, March 9, 2023

Hello, my friend, when encountering a SanDisk flash drive not detected by a computer, the priority for you is to check the connection problem. If you ensure the connection goes well, you can pin your hope on updating the outdated driver of your MacBook Air.

When checking the connection trouble, you can try an alternative USB port, adapter, cable, or so. Or, a direct plugging to another computer also works fine.

If your SanDisk flash drive is detected by other device, then I can determine that there is something wrong with your computer driver or OS. You need to update/reinstall macOS or upgrade the outdated driver.

If your drive is still not detected by computer, then I guess the drive is falling. You'd better replace it with a new one for your later storage work. Hope good luck~

People Also Ask

Read More Questions

Read More Advice From iBoysoft's Computer Experts

Fix The target volume is part of incomplete system on Mac

Fix 'The target volume is part of incomplete system' on Mac

Fix the error 'The target volume is part of incomplete system and can not be installed to.' when reinstalling macOS Catalina and other macOS versions.

News Tips

USB Anschluss funktioniert nicht am Mac

Behebung des nicht funktionierenden USB-Anschlusses am Mac [4 einfache Methoden]

Beschreibt, warum die USB-Anschlüsse am Mac nicht funktionieren und wie man das Problem behebt und die USB-Anschlüsse mit 4 effektiven Lösungen wieder zum Laufen bringt.

How to fix Time Machine Waiting to Complete First Backup error

How to Fix Time Machine Waiting to Complete First Backup?

A definite guide for fixing Time Machine 'Waiting to complete first backup' error. Analyze why Time Machine says 'Waiting to complete first backup'.

How to Tips