Home > Questions

WD Elements Hard Drive Not Mounting on Mac, How to Fix It?

I'm having a tough time trying to get my Mac to detect my external hard drive (WD 4TB Elements Hard drive). Before, it would mount and then unmount. After a while it would mount again. I was also able to see it in Disk Utility. I tried running First Aid when the drive appeared in Disk Utility, but this problem of mounting and unmounting still occurred. I unplugged the external hard drive and plugged it back in and this time it's rarely showing up in Disk Utility. I tried checking System Information and was able to see the drive connected via USB. I've heard about something called "fsck" in the Activity Monitor, and that may be the function that Macs use to fix the drive, but I was unable to find such function in the activity monitor. Any help would be greatly appreciated!

Best Answered by

iBoysoft author Ciki Liu

Ciki Liu

Answered on Monday, February 19, 2024

Does your MacBook come with a USB-A port that can support your USB drive directly? If not, check the USB adapter and USB hub your use for building the connection. A faulty USB adapter is likely to cause your WD external hard drive not mounting on Mac.

Newer Mac models are not equipped with traditional USB-A ports. Therefore, you have to use an extra USB adapter or USB hub to connect your WD external hard drive to the Mac. Since you've mentioned the disk is detected by your Mac but the connection is on and off, there's a big chance your adapter is wonky and causes the unstable connection.

To make sure the connection is working well, besides changing to a new adapter, you can do the followings:

Try a different USB port on your Mac. If one port doesn't make your WD external hard drive successfully mount on your Mac, switch to a different one.

Plug in your USB adapter slowly and tightly to avoid a wonky connection. Oftentimes, a loose connection between the storage media and your Mac can result in an external hard drive not working on Mac. Simply remove the disk and re-plug it.

Don't remember to reboot your MacBook after rebuilding the connection. If still, your WD not mounting on Mac after trying out a new USB adapter or USB port, the disk may be damaged or corrupted. You can use fsck command to repair a corrupted hard disk on Mac as you mentioned above. Here's how to do it.

Step 1. Open Terminal from the Launchpad.

Step 2. To view a list of all currently connected drives on your Mac, use the command below and hit Enter.

diskutil list

Step 3. Find your WD external disk and copy its path which looks like /dev/disk2.

Step 4. To boot your Mac in Single User Mode, restart it while holding down the Command and S keys.

Enter the following command:

/sbin/fsck hfs -fy /dev/disk2

 Note: replace hfs with the true file system and disk 2 with the actual disk path of your WD.

Step 5. Wait for the diagnosis and repair process. Once done, type in reboot and hit Enter to boot up your Mac.

People Also Ask

Read More Questions

Read More Advice From iBoysoft's Computer Experts

SanDisk Extreme Portable SSD not detected on Mac

SanDisk Extreme Portable SSD Not Detected/Recognized On Mac!

Ever encountered the issue that SanDisk Extreme Portable SSD is not showing up, detected, responsive, or mounted, on Mac? Don't worry, this article guides you to get it fixed successfully.

Mac Data Recovery Tips

Macでcom.apple.DiskManagement.disenterエラー119930868を修正する

com.apple.DiskManagement.disenter error -119930868/119930872

この記事を読んで、'com.apple.diskmanagement.disenterエラー-119930868/119930872/119930874'の原因と解決策を学びましょう。

disco rígido externo não está montando no Mac

Disco Rígido Externo Não Montando no Mac, Como Corrigir?

Tutorial para corrigir disco rígido externo não montando no Mac e recuperar dados do disco rígido externo desmontado.

recuperacion de datos mac