Home > Questions

What to Do FCPx Permission Denied and Cannot Open Any Libraries

When I worked on an FCPX project, I got a warning "...could not be opened. Permission denied". So I can't open any libraries. I tried restarting, deleting FCPX preferences and adjusting the setting Full Disk, but the problem still remains. Any fixes?

Best Answered by

iBoysoft author Sherry Song

Sherry Song

Answered on Monday, February 19, 2024

Hi, there may exist two cases:

( 1 )If you had those libraries opened at some point and the application crashed, it is possible that some lock files were left behind.

  1. Press Control and click one of the libraries then choose Show Package Contents.
  2. Press Command, shift, and period to show hidden files.
  3. After seeing two files .lock and .lock-info and one folder .lock-dir, drag the three out of the package to the desktop.
  4. Try opening the library. If it works, you can trash the lock files, and repeat for the other libraries.

( 2 )If you look at any folders in your Mac, then you see some files greyed out (probably with names starting with a period). If you don't see any, then your unhidden file actions may be wrong. Try holding down the Command key and the Shift key, type a period. The change in the Finder display of any folder should be apparent when you do that.

People Also Ask

Read More Questions

Read More Advice From iBoysoft's Computer Experts

Macでのユーティリティフォルダ

Mac/MacBookにあるユーティリティフォルダはどこですか?

あなたのMacBookやデスクトップMac上のユーティリティフォルダがどこにあるか疑問に思っていますか?Macでユーティリティフォルダにアクセスする5つの方法とユーティリティフォルダとは何かを学びましょう。

mise en veille des disques durs sur Mac lorsque c'est possible

Activer ou non la mise en veille des disques durs sur Mac

Ce message vise à vous faire comprendre la fonctionnalité permettant de mettre en veille les disques durs lorsque cela est possible sur macOS et répond à la question de savoir si vous devez l'activer sur Mac.

use iMac as monitor for PC

How to Use iMac As a Monitor for PC [Step-by-Step Guide]

Have an older iMac? Using it as a monitor for PC is a good idea. Read this article to learn how to use iMac as Monitor for PC.

News Tips