Home > Questions

How to fix a USB that won't reformat or delete files?

I have tried to use disk utility, drag and drop files in the trash, and reformat (currently on (MS DOS32), but my SanDisk USB won't accept files (some were loaded on before the issue occurred) and won't delete any. I specifically bought this USB stick for my work CPU — and it has not worked from day one. An error message says the USB can't reformat or delete files due to the partition map. Any help? Much appreciated.

Best Answered by

iBoysoft author Anna Yuan

Anna Yuan

Answered on Thursday, May 16, 2024

The error prompt showing "the USB can't reformat or delete files due to the partition map." may appear when you are formatting the USB flash drive in Mac's Disk Utility app. Generally, the common reason for a USB stick showing this error on Mac is that it is physically locked or it has a corrupted partition map. Therefore, check if the physical lock on USB is toggled down to protect it from being written first.

Basically, you can find the physical write protection switch on all standard USB drives, SD cards, or SD card readers. To disable the write protection on your USB drive, do the following:

Step 1. Find the lock button on the USB drive.

Step 2. Slide the USB mechanical lock up to the unlock position.

Step 3. Connect the USB to your Mac. Try to format the USB drive on Mac or delete files from it to see if the error still occurs.

If the error message still prompts, maybe the problem is not the write protection. It could be the corrupted partition map, to fix a corrupted partition map, try to use Disk Utility First Aid to solve it.

  1. Open Disk Utility from Finder > Applications > Utilities.
  2. Connect the USB drive to your Mac.
  3. Click View > Show All Devices in Disk Utility.
  4. Select the USB stick from the left device list and click First Aid.
  5. Choose Run to start checking and repairing the USB drive.
  6. When the process completes, click Format again.

People Also Ask

Read More Questions

Read More Advice From iBoysoft's Computer Experts

bash cd too many arguments zsh string not in pwd

Bash: cd: to many arguments & Zsh: cd: string not in pwd:

If the already-installed Terminal or another command shell throws you an error 'bash: cd: too many arguments' or 'zsh: cd: too many arguments' on your computer, come into this article for solutions.

How to Tips

error com.apple.DiskManagement disenter

¿Cómo arreglar el error 0 de com.apple.DiskManagement.disenter en Mac?

Guía para arreglar 'error 0 de com.apple.DiskManagement.disenter' mediante métodos probados. También te ayudará a encontrar las causas de este error y evitar la pérdida de datos.

recuperacion de datos mac

com.apple.DiskManagement disenter error

How to fix com.apple.DiskManagement.disenter error 0 on Mac?

Guide to fix 'com.apple.DiskManagement.disenter error 0' via proven ways. Also, help you find out the causes of this error and avoid data loss.

Mac Data Recovery Tips